JWorld@TW the best professional Java site in Taiwan
      註冊 | 登入 | 全文檢索 | 排行榜  

» JWorld@TW » Servlet/JSP 討論區  

按列印兼容模式列印這個話題 列印話題    把這個話題寄給朋友 寄給朋友   
reply to postflat modego to previous topicgo to next topic
本主題所含的標籤
無標籤
作者 Tomcat 啟動時亂碼問題
weberhwang





發文: 45
積分: 0
於 2018-12-31 11:53 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
大家好
我的
作業系統 Windows10 pro 繁體中文版
Tomcat 版本 8.5.37

在使用 C:\apache-tomcat-8.5.37\bin\startup.bat 啟動tomcat時,
都會發現cmd視窗中有亂碼,如下

31-Dec-2018 19:53:15.116 鞈? [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployDirectory Deployment of web application directory [C:\apache-tomcat-8.5.37\webapps\ROOT] has finished in [248] ms

31-Dec-2018 19:53:15.118 鞈? [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-8081"]

31-Dec-2018 19:53:15.129 鞈? [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["ajp-nio-8009"]

31-Dec-2018 19:53:15.132 鞈? [main] org.apache.catalina.startup.Catalina.start Server startup in 2250 ms

目前試過下面兩個方式皆無法解決
(1)C:\apache-tomcat-8.5.37\conf\server.xml中加入下面紅色那一行
<Connector port="8081" protocol="HTTP/1.1"
connectionTimeout="20000"
URIEncoding="utf-8"
redirectPort="8443" />
(2)C:\apache-tomcat-8.5.37\bin\catalina.bat中加入下面這行
set "JAVA_OPTS=-Dfile.encoding=utf-8"

請教各位先進該如何解決,謝謝。


weberhwang edited on 2018-12-31 11:59
reply to postreply to post
話題樹型展開
人氣 標題 作者 字數 發文時間
282 Tomcat 啟動時亂碼問題 weberhwang 1048 2018-12-31 11:53
» JWorld@TW »  Servlet/JSP 討論區

reply to postflat modego to previous topicgo to next topic
  已讀文章
  新的文章
  被刪除的文章
Jump to the top of page

JWorld@TW 本站商標資訊

Powered by Powerful JuteForum® Version Jute 1.5.8