JWorld@TW the best professional Java site in Taiwan
      註冊 | 登入 | 全文檢索 | 排行榜  

» JWorld@TW » JDBC/SQL討論區 » Connection Pool  

按列印兼容模式列印這個話題 列印話題    把這個話題寄給朋友 寄給朋友    訂閱主題
reply to postflat modego to previous topicgo to next topic
本主題所含的標籤
無標籤
作者 web.xml 設定中文編碼出現錯誤<init-param>
alex038





發文: 4
積分: 0
於 2007-11-30 15:02 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
請教大家,以下訊息是init-param設定有誤嗎? 若把<init-param>移除,寫入mysql時中文data會有亂碼,請問如何設定,謝謝!

1
2
3
4
5
6
7
8
9
10
500 Servlet Exception
WEB-INF/web.xml:3: <init-param> cannot be used with a ConnectionPoolDataSource.
Use the init-param key as a tag, like <key>value</key>
 
1: <?xml version='1.0' encoding='Big5'?>
2: <web-app>
3:   <database>
4:      <jndi-name>jdbc/mysql</jndi-name>
5:      <driver type="com.mysql.jdbc.jdbc2.optional.MysqlConnectionPoolDataSource">
 


web.xml
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
<?xml version='1.0' encoding='Big5'?>
<web-app>
  <database>
     <jndi-name>jdbc/mysql</jndi-name>
     <driver type="com.mysql.jdbc.jdbc2.optional.MysqlConnectionPoolDataSource">
        <url>jdbc:mysql://localhost:3306/school</url>
        <user>root</user>
        <password>12345</password>        
     </driver>
     <prepared-statement-cache-size>8</prepared-statement-cache-size>
     <max-connections>20</max-connections>
     <max-idle-time>30s</max-idle-time>    
     <init-param useUnicode="true" characterEncoding="MS950"/> 
  </database>
</web-app>


我的環境是 resin-pro-3.1.3 + mysql5.0.45


reply to postreply to post
話題樹型展開
人氣 標題 作者 字數 發文時間
3642 web.xml 設定中文編碼出現錯誤<init-param> alex038 1105 2007-11-30 15:02
3274 Re:web.xml 設定中文編碼出現錯誤<init-param> koji 654 2007-12-01 01:05
3252 Re:web.xml 設定中文編碼出現錯誤<init-param> alex038 613 2007-12-03 08:54
3217 Re:web.xml 設定中文編碼出現錯誤<init-param> koji 600 2007-12-03 09:15
3217 Re:web.xml 設定中文編碼出現錯誤<init-param> alex038 385 2007-12-03 16:33
3191 Re:web.xml 設定中文編碼出現錯誤<init-param> koji 115 2007-12-03 16:36
3479 Re:web.xml 設定中文編碼出現錯誤<init-param> alex038 628 2007-12-03 16:50
» JWorld@TW »  JDBC/SQL討論區 » Connection Pool

reply to postflat modego to previous topicgo to next topic
  已讀文章
  新的文章
  被刪除的文章
Jump to the top of page

JWorld@TW 本站商標資訊

Powered by Powerful JuteForum® Version Jute 1.5.8