JWorld@TW the best professional Java site in Taiwan
      註冊 | 登入 | 全文檢索 | 排行榜  

» JWorld@TW » Jute 討論區  

按列印兼容模式列印這個話題 列印話題    把這個話題寄給朋友 寄給朋友   
reply to topicthreaded modego to previous topicgo to next topic
本主題所含的標籤
無標籤
作者 我用ie登入有問題
aladdin

老婆不准我用兒子照片



發文: 175
積分: 3
於 2003-12-04 11:25 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
我在公司有兩部電腦,一部是win 2000 server,一部是win 2000 pro。用的都是ie 6,所有的update都裝了。自從上星期四開始,win 2000 pro沒有辦法登入jsptw,win 2000 server則是有時可以,有時不行。

而且,不能登入時,問的密碼和使用者姓名都沒有出現錯誤,問完之後,就回到首頁。如果登入成功,我會看到上次登入的時間,就是我剛才失敗的那一次。也就是說,我上次的登入,其實已經在資料庫中留下成功的紀錄,但還是沒有辦法認定我是會員。有人知道是怎麼回事嗎?

我在ie裡能調的,兩部機器已經一模一樣了。現在這個留言是在netscape上寫的,所以,應該問題也不是公司的防火牆。


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
browser

戀香

版主

發文: 3570
積分: 1
於 2003-12-04 11:38 user profilesend a private message to usersend email to browserreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
aladdin wrote:
我在公司有兩部電腦,一部是win 2000 server,一部是win 2000 pro。用的都是ie 6,所有的update都裝了。自從上星期四開始,win 2000 pro沒有辦法登入jsptw,win 2000 server則是有時可以,有時不行。

而且,不能登入時,問的密碼和使用者姓名都沒有出現錯誤,問完之後,就回到首頁。如果登入成功,我會看到上次登入的時間,就是我剛才失敗的那一次。也就是說,我上次的登入,其實已經在資料庫中留下成功的紀錄,但還是沒有辦法認定我是會員。有人知道是怎麼回事嗎?

我在ie裡能調的,兩部機器已經一模一樣了。現在這個留言是在netscape上寫的,所以,應該問題也不是公司的防火牆。


最近我也收到有一個會員的來信
他也是說無法使用 ie 登入 ....
okok ... 我馬上處理 ...
感謝告之 ....

PS. 己經通知 Jute 開發人員 ....


browser edited on 2003-12-04 11:41
reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
browser

戀香

版主

發文: 3570
積分: 1
於 2003-12-05 03:12 user profilesend a private message to usersend email to browserreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
目前推測是 dns cache 的問題 ...
因為約兩個禮拜前 .. 又換過一次 ip ....
不知道是不是主因 ......


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
rainman





發文: 67
積分: 1
於 2003-12-06 09:04 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
Cookie Turn on了嗎?

reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
aladdin

老婆不准我用兒子照片



發文: 175
積分: 3
於 2003-12-06 12:20 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
是的,兩部機器裡的ie設定一模一樣(我還沒有時間去檢查registry的部分),一部有時能看,一部是完全不能。

reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
rainman





發文: 67
積分: 1
於 2003-12-08 01:31 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
是能连上jsptw,但不能login,对吗?一般都是cookie的问题。

reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
aladdin

老婆不准我用兒子照片



發文: 175
積分: 3
於 2003-12-08 06:32 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
有什麼測試的頁面可以讓我回報的嗎?

我自己如果遇到網友有這種問題,會臨時開放一個診斷頁面,讓他們把診斷的結果寄回給我。


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
anthonychen

外線交給我

版主

發文: 2033
積分: 8
於 2003-12-08 10:11 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
之前有遇過一個情形,跟aladdin的情形類似,也是登入後明明首頁上方歡迎
的是我的帳號,但是我還是無法 post 文章,系統會提示我要我登入。我是用
IE 6.0 sp1 on Windows XP。

這種情形我在 cjsdn 與 JSPtw 都有遇到過,後來試著清一清IE的cache , 刪除
自動完成所儲存的內容,不知是不是有發生效用,後來就正常了。

.....(好像不能幫到什麼忙).....


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
ymshin





發文: 277
積分: 4
於 2003-12-08 10:57 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
是 cookie 低問題可能性較大, 先確定沒 ban 住 jsptw 再說, 要是給它 dynamic 沒永久允許, 也速會那個低~ 不是 jute 有問題

reply to postreply to post
作者 Re:我用ie登入有問題 [Re:ymshin]
aladdin

老婆不准我用兒子照片



發文: 175
積分: 3
於 2003-12-08 12:20 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
ymshin wrote:
是 cookie 低問題可能性較大, 先確定沒 ban 住 jsptw 再說, 要是給它 dynamic 沒永久允許, 也速會那個低~ 不是 jute 有問題


我問過我們MIS,他的答案也類似。他的意思是說:

1. 防火牆如果reparse http header,會擋住 cookie,但是(他發誓)他沒有這樣做(我算是公司裡比較和他能談話的人,之前也給我不少方便)。

2. 如果IE曾經ban過這個網站。這點在點選preference下的隱私的時候,應該可以看到這個限制,刪掉就好。我沒有看到這樣的規則。 不過由於我在我自己的機器上,不是以administrator這個名字登入的。我可能還是得到windows registry裡查一查有沒有怪東西存在。

如果有結果,我會post上來,謝謝大家的指教。


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
aladdin

老婆不准我用兒子照片



發文: 175
積分: 3
於 2003-12-08 16:28 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
早上清掉了幾次ie cache,發現jsptw的cookie好像不會寫下來。做了許多設定都沒辦法。

後來讓我們MIS在我的位置上奮鬥了三個小時,(我則在另一部電腦上逛jsptw),經歷千辛萬苦的重灌(在ie6 sp3上要重新灌 ie6 sp1,得要欺騙電腦不少東西),升級到sp3以後,才發現之前很多的application設定都出了點小問題。不過,已經可以正確的登入了。


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
browser

戀香

版主

發文: 3570
積分: 1
於 2003-12-08 16:32 user profilesend a private message to usersend email to browserreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
aladdin wrote:
早上清掉了幾次ie cache,發現jsptw的cookie好像不會寫下來。做了許多設定都沒辦法。

後來讓我們MIS在我的位置上奮鬥了三個小時,(我則在另一部電腦上逛jsptw),經歷千辛萬苦的重灌(在ie6 sp3上要重新灌 ie6 sp1,得要欺騙電腦不少東西),升級到sp3以後,才發現之前很多的application設定都出了點小問題。不過,已經可以正確的登入了。


所以問題是 ie6 嗎 ???
是 sp1 有問題 還是 sp3 有問題 ....
看來我得要發 e-mail 通知所有的會員 .....


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
ymshin





發文: 277
積分: 4
於 2003-12-08 16:39 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
我前兩星期才重弄電腦,2000 pro ie6, 所有 patch 都有,沒問題.

reply to postreply to post
作者 Re:我用ie登入有問題 [Re:browser]
anthonychen

外線交給我

版主

發文: 2033
積分: 8
於 2003-12-08 16:51 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
browser wrote:
所以問題是 ie6 嗎 ???
是 sp1 有問題 還是 sp3 有問題 ....
看來我得要發 e-mail 通知所有的會員 .....

我是在Windows XP sp1 使用 IE 6 sp1,只遇過一次這種問題。把所有設定還原
為預設並清理過 cache & cookie 後就在也沒發生了(糊裡糊塗好的Tongue)


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:ymshin]
阿熊



版主

發文: 17
積分: 0
於 2003-12-08 16:54 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
ymshin wrote:
我前兩星期才重弄電腦,2000 pro ie6, 所有 patch 都有,沒問題.

时间设得对吗
有没有使用代理


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:阿熊]
ymshin





發文: 277
積分: 4
於 2003-12-08 16:58 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
阿熊 wrote:
时间设得对吗
有没有使用代理


是指 jsptw 的時間嗎? 正確, 我沒用 proxy 直接連.


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:browser]
aladdin

老婆不准我用兒子照片



發文: 175
積分: 3
於 2003-12-08 17:57 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
browser wrote:
所以問題是 ie6 嗎 ???
是 sp1 有問題 還是 sp3 有問題 ....
看來我得要發 e-mail 通知所有的會員 .....


整個流程的目的是要重灌ie6,但是因為之前已經做了安全性的patch(無法移除),所以不接受用ie6 sp1重灌。其實現在到底是sp幾,我也搞不清楚——我們MIS說sp3就sp3吧!

因為無法重灌,所以,必須讓系統以為我的ie6的版本比sp1遜。於是我們MIS就在那邊改windows registry,說是騙系統以為這是舊版本。改了半天,改到連ie都無法成功開啟之後,就重開進入安全模式,花了很久的時間(用已經下載好的版本)重灌ie6 sp1——第一次感覺2.8G的P4也可以這麼慢。然後重新開機,登入jsptw就正常了。之後就是把所有的patch再加上來(用windows update)。可是之前修改registry的時候,大概有動到一些不該動的東西,所以有許多東西要修復(比如m$ office)。剛剛還在一個一個程式的檢查。

我覺得應該不是ie的問題,而是我的機器上有些東西不對了,以致於cookie沒辦法儲存。我們MIS剛剛要我backup所有的檔案,他覺得硬碟有問題。


reply to postreply to post
作者 Re:我用ie登入有問題 [Re:aladdin]
rainman





發文: 67
積分: 1
於 2003-12-09 01:58 user profilesend a private message to userreply to postreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
Cookie没法写入的问题比较古怪哦, 我之前都没听说过啊.

reply to postreply to post
» JWorld@TW »  Jute 討論區

reply to topicthreaded modego to previous topicgo to next topic
  已讀文章
  新的文章
  被刪除的文章
Jump to the top of page

JWorld@TW 本站商標資訊

Powered by Powerful JuteForum® Version Jute 1.5.8